Page tree

Skip to end of metadata
Go to start of metadata

Prerequisites

  • Parasoft Jtest DTP Engine 10.3 or higher
  • Eclipse 3.6-3.8, 4.2-4.7

Before you start working with Unit Test Assistant, ensure that Jtest DTP Engine is enabled and properly configured; see Enabling and Configuring the DTP Engine for details.

Supported frameworks

Currently, the following frameworks are supported:

  • JUnit4 4.11 or later
  • JUnit4Parametrized
  • JUnitParams 1.0.6 or later
  • Mockito 1.7 or later
  • PowerMock 1.6.5 or later
  • Spring 3.2 or later
  • Spring Boot 1.4 or later

We recommend using Java Runtime Environment provided by Oracle Corporation in your environment. Other free and open source implementations may cause issues with the proper functioning of Unit Test Assistant.

  • No labels