Your system must meet the following requirements to run Selenic.

Selenium

Selenic supports Selenium version 3 starting with 3.10.

OS

64-bit editions of the following operating systems.

Windows

MacOS

Linux

Recording in the browser with Parasoft Recorder is not supported. The following distributions are supported:

Software

Selenium WebDrivers

The appropriate WebDriver executable for your browser is required. The following browsers and associated WebDrivers are supported:

See WebDriver Configuration for details about downloading and configuring Selenic to use the WebDrivers.

Additional Prerequisites

The following tools and components are required to enable the full Selenic workflow:

IDE

Plugging Selenic into a supported IDE provides a UI for creating and executing Selenium tests. The plug-in also enables the Selenic to provide recommendations on how to update and maintain tests.

Selenic plugs into Eclipse 4.4+ 

Maven

Selenic supports test execution with Maven. Maven is also required to leverage the test impact analysis functionality. 

Selenic supports Maven 3.0 or later 

SOAtest Server

SOAtest server is only required if you want to create API tests during UI test execution.

Selenic works with SOAtest Server 9.10.7 or later. 

API Test Creation Limitations

API test creation is not supported in the following browsers and WebDrivers: