Page tree

Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1 Next »

Importing and Correlating Requirements from RMS


In-File Suppressions



Compiler Support

We've added support for the following compilers:

Compiler NameCompiler Acronym
ARM Compiler 6.14armclang_6_14
Clang C/C++ Compiler v 10.0 (x86_64)clang_10_0
GNU GCC 10.x (x86_64)gcc_10-64
IAR Compiler for ARM v. 8.50xiccarm_8_50
Metaware DesignWare ARC C/C++ Compiler P-2019.09ccac_2019_09

IDE Support

New Eclipse versions was: <4.9, <4.15 (2020-03)


Other Enhancements



Deprecated and Removed Support for Environments

Deprecated Compilers

Support for the following compilers is deprecated and will be removed in future releases:

  • ARM Compiler 6.6
  • Intel C++ Compiler v 18.0
  • GCC for Tricore 4.9.x

Deprecated Platforms

Support for the following platforms is deprecated and will be removed in future releases:

  • Windows Server 2008
  • Windows Server 2012

Removed IDEs

Support for the following IDEs is removed:

  • ARM Development Studio earlier than 5.28
  • Eclipse 3.8
  • Renesas e2 Studio 5.1
  • WindRiver Workbench 3.3
  • Texas Instruments Code Composer Studio 6.0

Removed Source Control Management Systems

Support for the following SCMs is removed:

  • AccuRev
  • ClearCase
  • CVS
  • Serena Dimensions
  • StarTeam
  • Synergy CM
  • Visual Source Safe





  • No labels